Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like minded biker friends. We have one common religion - Bikeism.

T-shirt
Magazine
Castrol Power 1

Hot days = molten tar = slip/slide.

Our Partners



User Tag List

Page 3 of 133 FirstFirst 12345671353103 ... LastLast
Results 21 to 30 of 1324
Like Tree543Likes

Thread: 2017 Duke 390 Owners Reviews and Experiences

  1. #21
    Rusted chiragsthakur's Avatar
    Join Date
    May 2011
    Location
    Vikhroli,Mumbai
    Posts
    323
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    Strangely somehow got an issue with ECU after today's ride twice.
    It breaks heart when a new bike starts behaving weird. KTM could have easily ironed out every single issue after almost 3 years of D390 experience.

    Lets hope it's not a major problem though. But I think after such thorough testing, how on Earth does a manufacturer miss out these little errors.
    Catch me on youtube : IGR

    Yamaha RX135 (1998) - Stolen

    Yamaha R15 V2 - Composure redefined

    KTM Duke 390 2017 - Starting to know the Beast Incarnet

  2. #22
    Rookie
    Join Date
    May 2009
    Location
    Hisar
    Posts
    36
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by chiragsthakur View Post
    It breaks heart when a new bike starts behaving weird. KTM could have easily ironed out every single issue after almost 3 years of D390 experience.

    Lets hope it's not a major problem though. But I think after such thorough testing, how on Earth does a manufacturer miss out these little errors.
    Yes Chirag, On a new model where a lot of features controlled by ECU, its really scary to see ECU not working. Luckily it happened when I reached back home, If it would have happened in middle of road, It would have been a real bad story to tell altogether. As the Bike doesn't even start when ECU fails. Now lets just hope that whatever more problems have to be detected, they get detected soon and fixed in guarantee period. Availability of spares for new model will also be another question.
    ksuresh92 likes this.

  3. #23
    s1d
    s1d is offline
    Rusted
    Join Date
    Feb 2009
    Posts
    3,123
    Mentioned
    135 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    Yes Chirag, On a new model where a lot of features controlled by ECU, its really scary to see ECU not working. Luckily it happened when I reached back home, If it would have happened in middle of road, It would have been a real bad story to tell altogether. As the Bike doesn't even start when ECU fails. Now lets just hope that whatever more problems have to be detected, they get detected soon and fixed in guarantee period. Availability of spares for new model will also be another question.
    Your video isn't clear & doesn't provide much information apart from showing the bike not starting a couple of times but starts up subsequently. Either mention the error message that came up on the console or post a clear pic so It might help us better understand what it could possibly be.
    In most cases it is not the ECU that goes bad, rather some sensor/engine parameters that trigger an error code.
    The real glory is being knocked to your knees and then coming back. That's real glory. That's the essence of it.

  4. #24
    Rookie
    Join Date
    May 2009
    Location
    Hisar
    Posts
    36
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by s1d View Post
    Your video isn't clear & doesn't provide much information apart from showing the bike not starting a couple of times but starts up subsequently. Either mention the error message that came up on the console or post a clear pic so It might help us better understand what it could possibly be.
    In most cases it is not the ECU that goes bad, rather some sensor/engine parameters that trigger an error code.
    Yes coz it was dark at night, The error cant be readable in video,

    So I went for a ride in evening, Total ride may be of approx 40 - 45 kms, Reached back home and after city driving when I left the bike on idle radiator fan turned on( Quite normal with KTM Duke) Checked the temp meter it was showing normal (Half, it always remains at half after initial warm up) While parking the bike inside Bike got turned off due to low rev and leaving clutch, Suddenly Low oil light glows up and within seconds a red banner popped up from below saying " ECU not working" Turned off the ignition to reset ECU and turned on again, it started normally, Just to ensure tried turning off and on couple of times and Again got ECU not working banner, with Low oil light and temp meter reached full all of a sudden Tried starting the bike and it didn't start, Tried putting Side stand, but warning didn't came up for side stand. Restarted ignition key and showing again normal temp but low oil light still glows, Revved the bike a little and the low oil light also goes away. To me it Seems like a failure of Oil level gauge. Rest probably be figured out at first service when they will connect for errors.

    Here is shorter version video of only the moment of problem


  • #25
    s1d
    s1d is offline
    Rusted
    Join Date
    Feb 2009
    Posts
    3,123
    Mentioned
    135 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    So I went for a ride in evening, Total ride may be of approx 40 - 45 kms, Reached back home and after city driving when I left the bike on idle radiator fan turned on( Quite normal with KTM Duke) Checked the temp meter it was showing normal (Half, it always remains at half after initial warm up) While parking the bike inside Bike got turned off due to low rev and leaving clutch, Suddenly Low oil light glows up and within seconds a red banner popped up from below saying " ECU not working" Turned off the ignition to reset ECU and turned on again, it started normally, Just to ensure tried turning off and on couple of times and Again got ECU not working banner, with Low oil light and temp meter reached full all of a sudden Tried starting the bike and it didn't start, Tried putting Side stand, but warning didn't came up for side stand. Restarted ignition key and showing again normal temp but low oil light still glows, Revved the bike a little and the low oil light also goes away. To me it Seems like a failure of Oil level gauge. Rest probably be figured out at first service when they will connect for errors.
    It could be due to a faulty oil pressure sensor (or a one off bad reading). Did it say verbatim "ecu not working" ? Surprised that it throws up such as error.
    I'd advice you head to the svc asap, and have their diag tool connected to troubleshoot further.
    Rohith Rot likes this.
    The real glory is being knocked to your knees and then coming back. That's real glory. That's the essence of it.

  • #26
    Rookie Rohith Rot's Avatar
    Join Date
    Oct 2015
    Location
    bangalore
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    Yes coz it was dark at night, The error cant be readable in video,

    So I went for a ride in evening, Total ride may be of approx 40 - 45 kms, Reached back home and after city driving when I left the bike on idle radiator fan turned on( Quite normal with KTM Duke) Checked the temp meter it was showing normal (Half, it always remains at half after initial warm up) While parking the bike inside Bike got turned off due to low rev and leaving clutch, Suddenly Low oil light glows up and within seconds a red banner popped up from below saying " ECU not working" Turned off the ignition to reset ECU and turned on again, it started normally, Just to ensure tried turning off and on couple of times and Again got ECU not working banner, with Low oil light and temp meter reached full all of a sudden Tried starting the bike and it didn't start, Tried putting Side stand, but warning didn't came up for side stand. Restarted ignition key and showing again normal temp but low oil light still glows, Revved the bike a little and the low oil light also goes away. To me it Seems like a failure of Oil level gauge. Rest probably be figured out at first service when they will connect for errors.

    Here is shorter version video of only the moment of problem

    Hi Bro. Sorry to hear this problem in such a new vehicle. i had a similar problem with my 2012 DUKE 200 . I got the whole meter itself changed it was not under warranty and i had to pay Rs 6500. i had all the errors that is showing for you. So anyway take it to the service station ASAP and get it checked.
  • Reply With Quote Reply With Quote

  • #27
    Moderator B7ACKTHORN's Avatar
    Join Date
    May 2011
    Location
    TN/TS Ooty/Telangana
    Posts
    6,499
    Blog Entries
    1
    Mentioned
    214 Post(s)
    Tagged
    3 Thread(s)

    Post Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    Yes coz it was dark at night, The error cant be readable in video,

    So I went for a ride in evening, Total ride may be of approx 40 - 45 kms, Reached back home and after city driving when I left the bike on idle radiator fan turned on( Quite normal with KTM Duke) Checked the temp meter it was showing normal (Half, it always remains at half after initial warm up) While parking the bike inside Bike got turned off due to low rev and leaving clutch, Suddenly Low oil light glows up and within seconds a red banner popped up from below saying " ECU not working" Turned off the ignition to reset ECU and turned on again, it started normally, Just to ensure tried turning off and on couple of times and Again got ECU not working banner, with Low oil light and temp meter reached full all of a sudden Tried starting the bike and it didn't start, Tried putting Side stand, but warning didn't came up for side stand. Restarted ignition key and showing again normal temp but low oil light still glows, Revved the bike a little and the low oil light also goes away. To me it Seems like a failure of Oil level gauge. Rest probably be figured out at first service when they will connect for errors.

    Here is shorter version video of only the moment of problem
    Though it is imperative to take your motorcycle to your nearest SVC. Here's what I can speculate. The reason why the ECU NOT WORKING is thrown, unlike the earlier ones where a certain code is displayed (though it still didn't make sense) the newer one perhaps just throws this "ENW" as a generic format for all errors. What I would like you to do is, check your engine oil level. Check if it stays on the right markings on the window. Secondly, it might be as simple as a loose connector somewhere or some improperly torqued ground nut/bolts, so let's not rule that out of the equation too. Many a times, a loose connector or a blown fuse is all that's the culprit.

    With that out of the way, I'd suggest you to check your engine oil, the console itself and all the wiring that goes with it for proper fitment. This should be interesting. Keep us abreast.

    Cheers!
    VJ
    44horses likes this.
    Once upon a time, a guy asked a girl 'Will you marry me?'
    The girl said, 'NO!'


    And the guy lived happily ever after and rode motorcycles and watched sport on a big screen TV, went fishing and surfing, and played golf a lot, and drank beer and scotch and had tons of money in the bank and left the toilet seat up and farted whenever he wanted.


    THE END

  • #28
    Addicted 44horses's Avatar
    Join Date
    Jan 2017
    Location
    MAQ KA19 CBE
    Posts
    78
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by hackergaurav View Post
    Strangely somehow got an issue with ECU after today's ride twice. After today's ride when I reached back home the bike got turned off while parking and when I tried to turn it on again it didn't started and gave ECU error on the screen. I am uploading the video also, as luckily I was recording when I faced this issue. Started doubting about the Engine Control Unit (computer) after today's ride. You can check the video at YouTube search for hackergaurav without space. Will raise this issue and her the bikes ECU checked at first service, hope to get a replacement under warranty of its really faulty. But then again don't know when it will be available.
    Seems the other owner also got this problem, for once or twice I guess he also stated that after continuous riding it went off.

    its just worrying, hope it doesn't happen with all bikes.

  • #29
    Addicted
    Join Date
    Apr 2016
    Location
    Bangalore
    Posts
    183
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Quote Originally Posted by 44horses View Post
    Seems the other owner also got this problem, for once or twice I guess he also stated that after continuous riding it went off.

    its just worrying, hope it doesn't happen with all bikes.

    Can you point out which other owner? I'll like to message him regarding this.

  • #30
    Rusted chiragsthakur's Avatar
    Join Date
    May 2011
    Location
    Vikhroli,Mumbai
    Posts
    323
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: 2017 Duke 390 Owners Reviews and Experiences

    Ya please let us know
    I have made the payment too :-/.
    Quote Originally Posted by 44horses View Post
    Seems the other owner also got this problem, for once or twice I guess he also stated that after continuous riding it went off.

    its just worrying, hope it doesn't happen with all bikes.
    Catch me on youtube : IGR

    Yamaha RX135 (1998) - Stolen

    Yamaha R15 V2 - Composure redefined

    KTM Duke 390 2017 - Starting to know the Beast Incarnet

  • Page 3 of 133 FirstFirst 12345671353103 ... LastLast

    Similar Threads

    1. Bajaj Dominar or KTM Duke 390 (2017)
      By msuthar25 in forum What Bike?
      Replies: 8
      Last Post: 05-22-2017, 11:43 AM
    2. 2017 KTM Duke 390, 250 and 200 launched
      By sunilg in forum News
      Replies: 272
      Last Post: 05-16-2017, 06:50 PM
    3. 2017 KTM 390 Duke Review: Rioters!
      By The Monk in forum Bike Reviews
      Replies: 18
      Last Post: 03-21-2017, 06:11 PM
    4. Replies: 242
      Last Post: 02-23-2017, 01:40 PM
    5. Is it Worth Waiting for 2017 KTM Duke 200 ?
      By pratyush997 in forum What Bike?
      Replies: 6
      Last Post: 10-01-2016, 01:20 AM

    Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •