Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

WE DESIGN ON

Lenovo ThinkPad
Castrol Power 1

Squeeze that brake, don’t grat a handful.

Our Partners

User Tag List

Results 1 to 4 of 4

Thread: Complete electrical failure on Bullet 500!

  1. #1
    Rookie
    Join Date
    Dec 2009
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking Complete electrical failure on Bullet 500!

    I'm not sure what the problem is, so I'll just go though all I did with the bike today so you can get the picture.

    I decided that I'd give the bike and good clean and so on, so I removed the seat, petrol tank, carby filter, battery and so on. I took the wires off the coil and cleaned the terminals and replaced them. I also cleaned and adjusted the spark plug. I cleaned and reconnected basically everything.

    Up until now the bike hasn't been in good working order electric wise. There has been some problem with the DC circuit. The horn, indicators and so on haven't been working. However the bike would always start easily and while riding it was perfect, save for those electrical problems.

    While checking the bike I then realised that there was no fuse and thought this must be the reason why the electrical problems had been happening. I made a big mistake when I decided to just connect the wires together withouth the fuse, since I didn't have a 20 amp fuse at that time. Even when I wired them together, the lights and horn still didn't work, so I think there may have been a different electrical problem up until today.

    Once I put the bike have together, I started it up and was about to start riding when I realised that it accelerated when I turned. The accelerator cable was stuck and therefore whenever I turned to the right, the engine accelerated. As I was testing this, the end of the cable that goes into the carby must have come up above it's usual resting place and stayed there.

    The bike revved as high as it possibly could. It was incredibly loud and I couldn't stop it. I tried turning the ignition off, that didn't help. So I pulled the cover off the spark plug to get it to stop.

    This worked and I adjusted the accelerator cable so that it worked fine, I turned the ignition on and tried to kick start the bike. It wouldn't start. I tested the lights and found that there was no power to anything on the bike.

    I have no idea where to go from here. I have checked the battery with a lightbulb and it works, but there is no power to anywhere else on the bike it seems. Remember that at this time the wires that are usually connected by a fuse were just hotwired together. I guess instead of the fuse being there to blow, something else got burnt out when the engive revved as much as it possibly could.

    I need suggestions as to what I should specifically check. I don't know where the problem could possibly be. I checked most of the connections but can't see any problems. What parts should I focus on in order to find the fault.

    In a week or two I should be able to take it to a mechanic, but right now that is not possible.

    I would really appreciate any help on this.

    Thankyou

  2. #2
    Rusted Aryan's Avatar
    Join Date
    Jan 2006
    Location
    New Delhi/ Shillong
    Posts
    18,673
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)

    Default

    Query Moved and Approved.
    ...in search of that perfect world - My Travel Blog :)

  3. #3
    Addicted Chinmay Dangre's Avatar
    Join Date
    Jul 2009
    Location
    Pune
    Posts
    134
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default bullseye

    where you from and which 500cc bullet you have?
    "CorePower"
    Motorcycle Performance
    Pune


  4. #4
    Rusted Aryan's Avatar
    Join Date
    Jan 2006
    Location
    New Delhi/ Shillong
    Posts
    18,673
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)

    Default

    Topic Locked.

    On request of OP, the thread is being hereby locked.
    ...in search of that perfect world - My Travel Blog :)

Similar Threads

  1. Comet Garage Ver VII Complete Overhauling
    By hisunil in forum Superbike And Imports
    Replies: 131
    Last Post: 02-24-2011, 08:38 PM
  2. Query on Electrical connections and relays.
    By avinrichards in forum Help Me!
    Replies: 14
    Last Post: 09-23-2009, 12:16 PM
  3. Electrical Problem: URGENT!!!
    By ashwinBK in forum Help Me!
    Replies: 8
    Last Post: 08-08-2009, 11:35 PM
  4. The Great New Zealand Roadtrip 2008 : Complete Blogs
    By Sunny in forum Roadtrips and Events
    Replies: 50
    Last Post: 06-30-2009, 01:39 AM
  5. Complete tool set....!
    By Devilpulsarian in forum General Biking Discussion
    Replies: 10
    Last Post: 03-27-2009, 12:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •