Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

WE DESIGN ON

Lenovo ThinkPad
Magazine
Castrol Power 1

Dawn & dusk make slight hard to adjust.

Our Partners

User Tag List

Results 1 to 3 of 3

Thread: Pulsar 220 Fi not starting! Help! :(

  1. #1
    Rookie
    Join Date
    Sep 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Pulsar 220 Fi not starting! Help! :(

    Hiiii...

    here i go once again with my Pulsar 220 Fi woes...i had starter relay problem with my 2008 Pulsar 220 Fi, called the Bajaj SC & they suggested to get a new modified starter relay fit, got that done asap, problem solved!

    Now after a month, my bike was idle for 2 days as i was out of town, whn i got back, the bike refuses to start!

    Usually when i put the key & turn the ignition on, it gives a long beeping like sound & then i can start it, but now i have noticed that there is no sound & the bike doesnt start at all, tried push starting it also, still no use.

    I got the battery checked & recharged, got the air filter cleaned, still no luck, even my local mechanic gave up!

    If any one has any idea what the problem is please help!

    Thanks,
    HunkFunk!

  2. #2
    Super Moderator Noor's Avatar
    Join Date
    Mar 2003
    Location
    Mumbai, Maharashtra, India.
    Posts
    2,324
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Default

    Query approved
    Happiness is finding you have another Gear left....

    Join xBhp On


  3. #3
    Rusted n_aditya's Avatar
    Join Date
    Feb 2010
    Location
    Bangalore
    Posts
    1,913
    Mentioned
    1 Post(s)
    Tagged
    2 Thread(s)

    Default

    Quote Originally Posted by hunkfunk View Post
    Usually when i put the key & turn the ignition on, it gives a long beeping like sound & then i can start it, but now i have noticed that there is no sound & the bike doesnt start at all, tried push starting it also, still no use.
    The long beep sound is a series of self checks or diagnostics that the FI system is performing.

    Check if any fuses are busted and replace them with correct rating if required. Sounds to me this could be an electrical problem but the pulsar owners can shed more light.
    ATGATT - Because hospital ceilings are boring !!!

Similar Threads

  1. Replies: 1
    Last Post: 09-08-2011, 05:31 PM
  2. Pulsar 220sf starting issue
    By zayed_ali890 in forum Help Me!
    Replies: 5
    Last Post: 06-12-2011, 08:52 AM
  3. Pulsar 510 UG 4.5 starting problem
    By pardeep_06 in forum Help Me!
    Replies: 4
    Last Post: 10-09-2010, 05:04 PM
  4. Replies: 4
    Last Post: 02-27-2010, 12:05 PM
  5. Pulsar 150 DTSi starting issues
    By Laddoo in forum Help Me!
    Replies: 3
    Last Post: 01-10-2009, 07:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •