Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like minded biker friends. We have one common religion - Bikeism.

T-shirt
Magazine
Castrol Power 1

Hot days = molten tar = slip/slide.

Our Partners



User Tag List

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
Like Tree3Likes

Thread: R15 V2.0 Engine Overheating Issue

  1. #11
    Addicted
    Join Date
    Apr 2010
    Location
    Dhaka, Bangladesh
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks fellow riders.

    will visit my mech's shop this friday and will tell him to inspect all these.
    the vents are not obstructed. no cleaning cloths there.
    vapor lock and/or blocked coolant passage seems to be the potential reason. the fan was working fine for last 3 months, all of a sudden this fan going weak seems unlikely, still, nevertheless, will check that too.

    let's see what happens, will keep you posted.

  2. #12
    Rusted dpak89's Avatar
    Join Date
    Nov 2010
    Location
    chennai/coimbatore
    Posts
    1,012
    Mentioned
    2 Post(s)
    Tagged
    2 Thread(s)

    Default

    @all: I also have the same issue in my 4k kms old V2. Except the fact that i dont have coolant overflow/drain.
    I had starting problem, the reason being valve clearance. After this was rectified/adjusted i am having overheating issue! At slow speeds/hills climbing overheating lights up. But while cruising(speed above 60kmph) it never shows up.
    Now is there a possibility that head gasket is not proper ?
    Rx is a Phoenix!!! It always rise from ashes!!

  3. #13
    Addicted
    Join Date
    Apr 2010
    Location
    Dhaka, Bangladesh
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    today, my bike's condition got even worse. after riding for 4-5 KMs the engine overheating light came-up and stayed on. switched off the engine and once started after 3-4 minutes the light was still on. morever, after reaching home, i noticed, the radiator fan was not running.

    from another mechanic i heard today that a faulty Radiator Fan Motor Relay could be the culprit. what do you guys think?

    taking my beast to the mech's shop tomorrow morning.

  4. #14
    Rusted abhimanyu31's Avatar
    Join Date
    Dec 2009
    Location
    Mumbai
    Posts
    1,438
    Mentioned
    86 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by ashaq54 View Post
    today, my bike's condition got even worse. after riding for 4-5 KMs the engine overheating light came-up and stayed on. switched off the engine and once started after 3-4 minutes the light was still on. morever, after reaching home, i noticed, the radiator fan was not running.

    from another mechanic i heard today that a faulty Radiator Fan Motor Relay could be the culprit. what do you guys think?

    taking my beast to the mech's shop tomorrow morning.
    Possible. Ask them to take out the relay and the fan and join it to a 12v source and see if the fan and the relay are functioning.
    Only a biker knows why a dog sticks his head out of a car window.

    Multum in Parvo - Much in Little

    "Yes, it is FAST! No, you CAN'T ride it!" - http://www.xbhp.com/talkies/general-...a-300-san.html

  5. #15
    Addicted
    Join Date
    Apr 2010
    Location
    Dhaka, Bangladesh
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hi all,

    since the SVC could not detect the specific reasons behind my bike's overheating issue, i had replaced both the thermostat and the fan motor relay. since then, the overheating issue seems to have been solved as the overheating light did not come up any more and also the bike was not heating up that much. it was heating up occasionally, like in heavy traffic, but the fan was kicking in and it was cooling off...which was quite normal.

    however, the overflow of the coolant through the drainage pipe has been there and, interestingly, it is evident only in the mornings. once i reach my office every morning which is around 5-6 KMs away, right after parking i see several drops of coolant flowing through the drainage pipe. and, it is not one or two drops, it is several drops every morning and there must be many drops while riding too. if this goes on, the entire amount of the coolant will overflow out of the reservoir...and, sooner or later, my bike will again start overheating.

    could you please shed some light on this issue...i am getting quite depressed with this issue these days. please help.

    regards.

  6. #16
    Rusted dpak89's Avatar
    Join Date
    Nov 2010
    Location
    chennai/coimbatore
    Posts
    1,012
    Mentioned
    2 Post(s)
    Tagged
    2 Thread(s)

    Default

    @Ashaq: Is your problem solved or still persistent?
    Rx is a Phoenix!!! It always rise from ashes!!

  7. #17
    Rookie
    Join Date
    Nov 2013
    Location
    Chennai
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: R15 V2.0 Engine Overheating Issue

    Even i am facing similar issues. I bought my bike only yesterday. After riding for 5-6km, the engine heats up and radiator fan keeps on engaging long after using the killswitch. Especially in heavy traffic conditions, the heating is significant. What could be the problem?

  8. #18
    Rusted Abishek94's Avatar
    Join Date
    Jun 2013
    Location
    bangalore
    Posts
    452
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)

    Default Re: R15 V2.0 Engine Overheating Issue

    Quote Originally Posted by ramanujbits View Post
    Even i am facing similar issues. I bought my bike only yesterday. After riding for 5-6km, the engine heats up and radiator fan keeps on engaging long after using the killswitch. Especially in heavy traffic conditions, the heating is significant. What could be the problem?

    A new bike will heat up more than normal. You shouldn't be worried unless the engine overheat warning light comes on.

  9. #19
    Rookie
    Join Date
    Nov 2013
    Location
    Chennai
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: R15 V2.0 Engine Overheating Issue

    thanks.. i asked in the showroom..even they said the same thing..

  10. #20
    Rookie pradoartz's Avatar
    Join Date
    Jan 2016
    Location
    Chennai
    Posts
    25
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default Re: R15 V2.0 Engine Overheating Issue

    Quote Originally Posted by ashaq54 View Post
    hi all,

    since the SVC could not detect the specific reasons behind my bike's overheating issue, i had replaced both the thermostat and the fan motor relay. since then, the overheating issue seems to have been solved as the overheating light did not come up any more and also the bike was not heating up that much. it was heating up occasionally, like in heavy traffic, but the fan was kicking in and it was cooling off...which was quite normal.

    however, the overflow of the coolant through the drainage pipe has been there and, interestingly, it is evident only in the mornings. once i reach my office every morning which is around 5-6 KMs away, right after parking i see several drops of coolant flowing through the drainage pipe. and, it is not one or two drops, it is several drops every morning and there must be many drops while riding too. if this goes on, the entire amount of the coolant will overflow out of the reservoir...and, sooner or later, my bike will again start overheating.

    could you please shed some light on this issue...i am getting quite depressed with this issue these days. please help.

    regards.
    You said that you have seen the radiator fan running while the engine gets hot, then why did you change the radiator fan relay??
    Then the real culprit is the thermostat.

    If the radiator fan doesn't work at all then you have to check with your relay, fan and wiring's.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. New Pulsar 150 UG4.5 Engine Overheating!!
    By nirantha in forum Help Me!
    Replies: 10
    Last Post: 01-26-2013, 12:54 PM
  2. [Photo Feature]: Engine overheating on Dazzler..!!
    By nikhil1033 in forum Help Me!
    Replies: 3
    Last Post: 05-05-2011, 08:09 AM
  3. Pulsar 180 UG4 Engine noise issue
    By VD17 in forum Help Me!
    Replies: 9
    Last Post: 10-03-2010, 10:40 PM
  4. Replies: 36
    Last Post: 06-28-2010, 07:55 PM
  5. [Help]: Engine overheating problem for pulsar 150
    By navpulsar150 in forum Help Me!
    Replies: 14
    Last Post: 09-11-2009, 11:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •