Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

Castrol Power 1

Avoid staying around those big vehicles.

Our Partners

Announcement

Collapse
No announcement yet.

yamaha szr - engine off while running

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • yamaha szr - engine off while running

    Hi guys,

    This problem that i am facing with my bike has become a real headache. I bought my bike way back in 2012, a Yamaha SZ-R. THe problem is that the engine just goes off while running. I have consulted many mechanics including the Yamaha SVC guys but they have no resolution for this. Some say carburettor overflow, petrol overflow, engine issues etc. I have gotten the piston heads of the motorcycle worked too but I am still suffering from the same problem. And now I have begun to have throttle issues as well.
    So I kindly request you to provide me some guidance or good mechanic in Bangalore who can solve this.

    Thank you in advance.
    Last edited by NewsReaper; 09-19-2018, 11:22 AM.

  • #2
    Re: yamaha szr - engine off while running

    Topic approved.

    Comment


    • #3
      Re: yamaha szr - engine off while running

      Will it start immediately after engine off or will you have hard time starting engine again ?? my guess is either there is electric short circuit somewhere (electric must be touching chassis or something while riding) or your fuel system is not working properly. maybe clogged fuel pipe, bad carburetor setting, clogged carburetor, there is water or impurity in your fuel, or low ideal setting. Since it is 2012 model chance are there is rust powder from fuel tank that clogged your pipe or carburetor. if your engine stops while your are waiting on traffic or something then it might low idle setting on carburetor.

      Comment


      • #4
        Re: yamaha szr - engine off while running

        Originally posted by Kn bik3r View Post
        Hi guys,

        This problem that i am facing with my bike has become a real headache. I bought my bike way back in 2012, a Yamaha SZ-R. THe problem is that the engine just goes off while running. I have consulted many mechanics including the Yamaha SVC guys but they have no resolution for this. Some say carburettor overflow, petrol overflow, engine issues etc. I have gotten the piston heads of the motorcycle worked too but I am still suffering from the same problem. And now I have begun to have throttle issues as well.
        So I kindly request you to provide me some guidance or good mechanic in Bangalore who can solve this.

        Thank you in advance.
        Sounds electrical, as if fueling related issues then you'd experience some bogging before stalling not the immediate conking off.

        Start from the spark plug and work up towards the CDI.
        Motorcycling Experience:
        2000 ~ 2017 Y2K Kinetic Zoom (Disposed at 15k)
        2011 ~ 2015 Hero Honda Karizma R (Sold at 56.5k)
        2013 ~ 2014 Bajaj Discover 100 4G (Sold at 16.5k)
        2015 ~ 2017 TVS Wego (Totaled at 18k)
        2015 - Bajaj Pulsar 220F (Currently 31k) < Garage Queen!
        2017 - Bajaj CT100B (Currently 21k) < 'Golden Quadrilateral' Runner!

        The Ride was Good, but Life is short, spend it Wisely!
        Adios Comrades!
        A.P. 2018

        Comment


        • #5
          Re: yamaha szr - engine off while running

          Originally posted by sus1024 View Post
          Will it start immediately after engine off or will you have hard time starting engine again ?? my guess is either there is electric short circuit somewhere (electric must be touching chassis or something while riding) or your fuel system is not working properly. maybe clogged fuel pipe, bad carburetor setting, clogged carburetor, there is water or impurity in your fuel, or low ideal setting. Since it is 2012 model chance are there is rust powder from fuel tank that clogged your pipe or carburetor. if your engine stops while your are waiting on traffic or something then it might low idle setting on carburetor.
          sure ill take this guidance and work accordingly !! let me check wat troubles it and update you once work is done.. !! thank you so much for your reply [emoji111]

          Comment


          • #6
            Re: yamaha szr - engine off while running

            Originally posted by Kn bik3r View Post
            sure ill take this guidance and work accordingly !! let me check wat troubles it and update you once work is done.. !! thank you so much for your reply [emoji111]
            A Pulsar 200 or 220 NS was facing the exact same problem some time back in my area. I would ask my friend if it was resolved and if yes, how. Might give you a heads up.

            Comment


            • #7
              Re: yamaha szr - engine off while running

              Originally posted by sdm_9999 View Post
              A Pulsar 200 or 220 NS was facing the exact same problem some time back in my area. I would ask my friend if it was resolved and if yes, how. Might give you a heads up.
              sure i would love to hear suggestions if that really cures... because its something that disturbs me often when riding.. !! thank you for your support bro [emoji111]

              Comment


              • #8
                Re: yamaha szr - engine off while running

                Originally posted by Kn bik3r View Post
                sure i would love to hear suggestions if that really cures... because its something that disturbs me often when riding.. !! thank you for your support bro [emoji111]

                Asked my friend, the issue with the Pulsar was the battery. But for your bike, he thinks it could be the CDI Unit. Also, he wanted to check if the fuel tank is catching air.

                Thanks,
                Soumyajit

                Comment


                • #9
                  Re: yamaha szr - engine off while running

                  Originally posted by sdm_9999 View Post
                  Asked my friend, the issue with the Pulsar was the battery. But for your bike, he thinks it could be the CDI Unit. Also, he wanted to check if the fuel tank is catching air.

                  Thanks,
                  Soumyajit
                  cool... i jus checked with mechanic here.. he said there are chances of engine got dusted due to bad fuelling or fuel tank probelm too or may be the coil issue... !! so will update you by evening bro !! thanks for your support [emoji111][emoji111]

                  Comment


                  • #10
                    Re: yamaha szr - engine off while running

                    Hi,
                    Have the similar problem with my 2011 model SZ-R. Engine will not turn off but will run like fuel is going to empty. Bike will move less than 10km speed at full throttle. After a 300-500 meter running, back to good condition. Happened this several times in the middle of traffic. But my mechanic is unable to find a solution and he doesnt beleive such problem exist in my bike.

                    Comment


                    • #11
                      Re: yamaha szr - engine off while running

                      Originally posted by Nidin View Post
                      Hi,
                      Have the similar problem with my 2011 model SZ-R. Engine will not turn off but will run like fuel is going to empty. Bike will move less than 10km speed at full throttle. After a 300-500 meter running, back to good condition. Happened this several times in the middle of traffic. But my mechanic is unable to find a solution and he doesnt beleive such problem exist in my bike.
                      Will ask my friend about this. Does this happen at a certain gear or certain speed or randomly at any gear or any speed? That will help a lot in identifying the problem.

                      Thanks,
                      Soumyajit

                      Originally posted by ashwinprakas View Post
                      Sounds electrical, as if fueling related issues then you'd experience some bogging before stalling not the immediate conking off.

                      Start from the spark plug and work up towards the CDI.
                      Bro, having to use this thread for a little bit of personal bidding. Trying to send you a PM but your inbox is full. Hope you see this and delete some
                      Last edited by sdm_9999; 10-15-2018, 01:19 AM.

                      Comment


                      • #12
                        Re: yamaha szr - engine off while running

                        Originally posted by sdm_9999 View Post
                        Bro, having to use this thread for a little bit of personal bidding. Trying to send you a PM but your inbox is full. Hope you see this and delete some
                        Sorry guess I missed that, would shortly clear my Inbox.
                        Motorcycling Experience:
                        2000 ~ 2017 Y2K Kinetic Zoom (Disposed at 15k)
                        2011 ~ 2015 Hero Honda Karizma R (Sold at 56.5k)
                        2013 ~ 2014 Bajaj Discover 100 4G (Sold at 16.5k)
                        2015 ~ 2017 TVS Wego (Totaled at 18k)
                        2015 - Bajaj Pulsar 220F (Currently 31k) < Garage Queen!
                        2017 - Bajaj CT100B (Currently 21k) < 'Golden Quadrilateral' Runner!

                        The Ride was Good, but Life is short, spend it Wisely!
                        Adios Comrades!
                        A.P. 2018

                        Comment


                        • #13
                          Re: yamaha szr - engine off while running

                          [QUOTE=sdm_9999;1354744]Will ask my friend about this. Does this happen at a certain gear or certain speed or randomly at any gear or any speed? That will help a lot in identifying the problem.

                          Thanks,
                          Soumyajit


                          Mostlrly happen this when i release the throttle to downshift. Without this problem also i feel engine has some lag in the initial acceleration. it was not like this before.

                          additional info: I have found some oil deposite in the airfilter box. (it is paper filter). mechanic says it is common. I have cleaned the airfilter 2-3 times in the last 1 year. replacing any parts will make any changes?

                          Thanks in advance
                          Nidin

                          Comment


                          • #14
                            Re: yamaha szr - engine off while running

                            [QUOTE=Nidin;1355060]
                            Originally posted by sdm_9999 View Post
                            Will ask my friend about this. Does this happen at a certain gear or certain speed or randomly at any gear or any speed? That will help a lot in identifying the problem.

                            Thanks,
                            Soumyajit


                            Mostlrly happen this when i release the throttle to downshift. Without this problem also i feel engine has some lag in the initial acceleration. it was not like this before.

                            additional info: I have found some oil deposite in the airfilter box. (it is paper filter). mechanic says it is common. I have cleaned the airfilter 2-3 times in the last 1 year. replacing any parts will make any changes?

                            Thanks in advance
                            Nidin
                            Checked with my friend. He suggests following:

                            1) Check the timing chain. The timing could be off.
                            2) The carburettor is always a suspect. But assuming you have checked it already.
                            3) Oil deposit in air filter box is nothing to worry about.

                            Thanks,
                            Soumyajit

                            Comment


                            • #15
                              Re: yamaha szr - engine off while running

                              [QUOTE=sdm_9999;1355461]
                              Originally posted by Nidin View Post

                              Checked with my friend. He suggests following:

                              1) Check the timing chain. The timing could be off.
                              2) The carburettor is always a suspect. But assuming you have checked it already.
                              3) Oil deposit in air filter box is nothing to worry about.

                              Thanks,
                              Soumyajit
                              1) Adjusted the chain tensioner. So far no problems found. Will reaplace the chain if required.
                              2) Already checked. It is good only.
                              3) Mechanic told me the same.

                              Another doubt. Why the engine feels rough in cold temperature . I mean in the early morning and night. It is so smooth in afternoon. Is it because of engine oil viscosity.
                              My daily commute is one way 15 KM in city with medium traffic. Engine doesnt feel much heat.
                              Which grade oil to be used to get the smoothness in cold as per my usage.

                              Comment

                              Working...
                              X