Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like minded biker friends. We have one common religion - Bikeism.

T-shirt
Magazine
Castrol Power 1

Stop braking before you start turning.

Our Partners

User Tag List

Results 1 to 6 of 6

Thread: Installed new block piston kit in suzuki fiero

  1. #1
    Rookie
    Join Date
    Apr 2019
    Location
    Aizawl
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Installed new block piston kit in suzuki fiero

    Installed new block piston kit, timing chain, camshaft and other wornout parts today but when everything is fitted back the bike is not starting....the compression in the intake and exhaust is now somewhat opposite in the sense that instead of sucking in the intake valve side it is releasing compression.....poured in some petrol by removing the sparkplug and when cranked....the smoke comes out from the intake valve side.....what could be the reason.... Please help
    Last edited by Tanpuia; 1 Week Ago at 09:58 PM.

  2. #2
    Moderator Samarth 619's Avatar
    Join Date
    Sep 2008
    Location
    Rajasthan
    Posts
    4,757
    Blog Entries
    4
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up Re: Installed new block piston kit in suzuki fiero

    Topic Approved.

  3. #3
    Addicted Throttlefreak's Avatar
    Join Date
    Dec 2016
    Location
    Pune
    Posts
    85
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Installed new block piston kit in suzuki fiero

    Quote Originally Posted by Tanpuia View Post
    Installed new block piston kit, timing chain, crank shaft and other wornout parts today but when everything is fitted back the bike is not starting....the compression in the intake and exhaust is now somewhat opposite in the sense that instead of sucking in the intake valve side it is releasing compression.....poured in some petrol by removing the sparkplug and when cranked....the smoke comes out from the intake valve side.....what could be the reason.... Please help
    From whatever you've written it seems that your engine is running in reverse. Please do not continue to run it that way. Assuming that the engine has been assembled correctly, I can say that you've probably reversed the polarity of the self start motor. Check it and if reversed, correct it.
    Last edited by Throttlefreak; 1 Week Ago at 08:26 PM.

  4. #4
    Rookie
    Join Date
    Apr 2019
    Location
    Aizawl
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Installed new block piston kit in suzuki fiero

    Quote Originally Posted by Throttlefreak View Post
    From whatever you've written it seems that your engine is running in reverse. Please do not continue to run it that way. Assuming that the engine has been assembled correctly, I can say that you've probably reversed the polarity of the self start motor. Check it and if reversed, correct it.
    The bike that i am restoring is the non-self start version of fiero...and yeah just to make sure in case i have fitted it wrongly.....i had removed everything and assembled it again but still having the same problem.....

  5. #5
    Addicted Throttlefreak's Avatar
    Join Date
    Dec 2016
    Location
    Pune
    Posts
    85
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Installed new block piston kit in suzuki fiero

    I too had a similar problem in my my bike (RX 100) but it ran just fine in reverse. The culprit was the spark timing. If the spark occurs just before the piston comes to the T.D.C. (Top Dead Centre) on the intake stroke the piston gets pushed back in reverse. Double check your spark and valve timings.

  6. #6
    Rookie
    Join Date
    Jan 2019
    Location
    mumbai
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Installed new block piston kit in suzuki fiero

    Get your timing adjusted correctly,and set your tappets at compression stroke using a feller gauge,check both intake and exhaust tappets are loose ,then adjust ,there has to be a little bit play on both tappets.

Similar Threads

  1. Project Build - Shogun piston modding an RX00 block / RX100 to RX110
    By FATAL1TY - X in forum Thumpers,2-Stroke And Exotics
    Replies: 49
    Last Post: 10-16-2018, 02:46 AM
  2. [Photo Feature]: 2008 Honda UniCorn Block Piston Probelm
    By sudip_talukdar in forum Help Me!
    Replies: 16
    Last Post: 12-01-2016, 08:14 PM
  3. SOS for shogun piston/block n rings
    By Shogun3086 in forum Thumpers,2-Stroke And Exotics
    Replies: 1
    Last Post: 10-12-2016, 11:20 AM
  4. pl help me to modify my suzuki fiero
    By nazar2k4 in forum Help Me!
    Replies: 11
    Last Post: 07-19-2009, 10:25 AM
  5. Block piston issue
    By psycho_omkar in forum Help Me!
    Replies: 27
    Last Post: 05-18-2009, 05:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •