Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like minded biker friends. Join the #16YearsOfxBhpCelebrations click here.

WE DESIGN ON

Lenovo ThinkPad
Magazine
Castrol Power 1

Look further to stay alive.

Our Partners

User Tag List

Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Mr.Noodles

Thread: Duke 250 Weird Problem.

  1. #1
    Rookie
    Join Date
    May 2019
    Location
    Teldrassil
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Duke 250 Weird Problem.

    Hi, thanks for approving my application.

    I have a 2017 Duke 250 which has a weird problem. Whenever I try to suddenly go fast, for eg : I was going at 40kmph at 2nd gear and someone crossed the road which forces me to slow down to around 20kmph, then upon trying to accelerate again, it would lag so much that it felt like it losses power completely for a while even if I rev hard. In a local language, it doesn't have a pickup. This doesn't happen if I go normally without slowing down, but I live in a hilly area with a lots of ups and downs.

    The second problem is (probably relate to the first), when I go downhill in a gear without accelerating (using engine as a means to slow down), the engine always dies upon pressing the clutch when trying to shift gears.

    My first suspects are either bad fuel pump, bad fuel injector, bad fuel quality or weak battery. Whats yours?

    I know I am not very good at describing my problem, there's a lot of proper terms that I don't know (in English) when talking about vehicles. So, please bear with me and tell me anything you don't understand in my question, I will try my best to explain it again. Any answer is appreciated. Thanks
    #bpk likes this.

  2. #2
    Moderator
    Join Date
    Dec 2015
    Location
    India
    Posts
    1,292
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Thread approved.

  3. #3
    Rusted Deathwing's Avatar
    Join Date
    Sep 2015
    Location
    Chennai
    Posts
    1,421
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Quote Originally Posted by Mr.Noodles View Post
    Hi, thanks for approving my application.

    I have a 2017 Duke 250 which has a weird problem. Whenever I try to suddenly go fast, for eg : I was going at 40kmph at 2nd gear and someone crossed the road which forces me to slow down to around 20kmph, then upon trying to accelerate again, it would lag so much that it felt like it losses power completely for a while even if I rev hard. In a local language, it doesn't have a pickup. This doesn't happen if I go normally without slowing down, but I live in a hilly area with a lots of ups and downs.

    The second problem is (probably relate to the first), when I go downhill in a gear without accelerating (using engine as a means to slow down), the engine always dies upon pressing the clutch when trying to shift gears.

    My first suspects are either bad fuel pump, bad fuel injector, bad fuel quality or weak battery. Whats yours?

    I know I am not very good at describing my problem, there's a lot of proper terms that I don't know (in English) when talking about vehicles. So, please bear with me and tell me anything you don't understand in my question, I will try my best to explain it again. Any answer is appreciated. Thanks
    Check the fuel pump, do a fuel pump flush or cleaning. Also check the throttle body. I had a issue with knocking, I just drained the fuel and put higher quality fuel and valla it was back to normal.

  4. #4
    Rookie
    Join Date
    May 2019
    Location
    Teldrassil
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Quote Originally Posted by Deathwing View Post
    Check the fuel pump, do a fuel pump flush or cleaning. Also check the throttle body. I had a issue with knocking, I just drained the fuel and put higher quality fuel and valla it was back to normal.
    They flushed the fuel pump (afaik) recently at the servicing centre, because there was some water in the tank. Should i flush it again?

    I use normal fuel though, could that be the problem?

  5. #5
    Rusted Deathwing's Avatar
    Join Date
    Sep 2015
    Location
    Chennai
    Posts
    1,421
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Quote Originally Posted by Mr.Noodles View Post
    They flushed the fuel pump (afaik) recently at the servicing centre, because there was some water in the tank. Should i flush it again?

    I use normal fuel though, could that be the problem?
    Get your fuel pump checked thoroughly.

  6. #6
    Rookie
    Join Date
    May 2019
    Location
    Teldrassil
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Quote Originally Posted by Deathwing View Post
    Get your fuel pump checked thoroughly.
    Although I don't have time to flush the fuel pump yet because of my exams. Today, I put the bike under a heavy rain for about 3 hours, the problem gets much worse with lots of misfire ( I hope misfire is the right word). Which let me believe it worsens when the engine is really cold.

  7. #7
    Rusted Deathwing's Avatar
    Join Date
    Sep 2015
    Location
    Chennai
    Posts
    1,421
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Water has seeped Into your tank again, change your fuel cap, drain your fuel tank completely, clean your fuel pump thoroughly, should be OK. Also check your air filter if clogged

  8. #8
    Rookie
    Join Date
    May 2019
    Location
    Teldrassil
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Duke 250 Weird Problem.

    Quote Originally Posted by Deathwing View Post
    Water has seeped Into your tank again, change your fuel cap, drain your fuel tank completely, clean your fuel pump thoroughly, should be OK. Also check your air filter if clogged
    I recently checked the air filter and it was super clean. I will drain and clean the fuel pump tomorrow and report back.. thank you v much.

Similar Threads

  1. Replies: 3
    Last Post: 02-19-2019, 01:01 PM
  2. Weird problem with my TB 500
    By akhilkaval in forum Help Me!
    Replies: 6
    Last Post: 02-10-2016, 10:44 AM
  3. Weird problem on my R15
    By nicky_cool_dude_2004 in forum Help Me!
    Replies: 3
    Last Post: 07-29-2011, 07:58 PM
  4. A weird problem
    By Rajesh N Dubal in forum Help Me!
    Replies: 10
    Last Post: 02-11-2011, 12:13 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •