Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like minded biker friends. Join the #16YearsOfxBhpCelebrations click here.

T-shirt
Magazine
Castrol Power 1

Always keep the chain well lubricated.

Our Partners

User Tag List

Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
Like Tree1Likes

Thread: Yamaha Ray Z missing problem only when cold! Help me out guys

  1. #11
    Rookie
    Join Date
    May 2019
    Location
    Teldrassil
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Yamaha Ray Z missing problem only when cold! Help me out guys

    I don't know if this helps but happens with our brand new Ray Z too, the service says it's normal. Happens with brand new Honda Grazia as well. It seems its a common issue with scooters.

  2. #12
    Rookie
    Join Date
    Jan 2018
    Location
    Hyderabad
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Yamaha Ray Z missing problem only when cold! Help me out guys

    Quote Originally Posted by Dani52war View Post
    Yeah I'm thinking of changing the rectifier and the cdi. Do you know the price of the rectifier? When you change the rectifier did it solve the missing problem? Anyway thank you for you valuable suggestion....Highly appreciated!
    Get the rectifier cdi checked at a electrical mechanic shop or test it yourself using a volt meter.. have the air filter also inspected and also check the carb for any blockage or leakage get it retuned if spark plug color are in black soot. After retuning it should be light grey..
    Jaison3 likes this.

  3. #13
    Rookie
    Join Date
    Jul 2019
    Location
    Guwahati
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Yamaha Ray Z missing problem only when cold! Help me out guys

    Quote Originally Posted by sallubhai786 View Post
    Get the rectifier cdi checked at a electrical mechanic shop or test it yourself using a volt meter.. have the air filter also inspected and also check the carb for any blockage or leakage get it retuned if spark plug color are in black soot. After retuning it should be light grey..
    Okay I will buy a new rectifier and get the cdi check.

  4. #14
    Rookie
    Join Date
    Apr 2013
    Location
    Bangalore
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Yamaha Ray Z missing problem only when cold! Help me out guys

    Quote Originally Posted by Mr.Noodles View Post
    I don't know if this helps but happens with our brand new Ray Z too, the service says it's normal. Happens with brand new Honda Grazia as well. It seems its a common issue with scooters.

    I am also facing same issue with my brand new Yamaha Ray Z(bought July 2019) - Whenever I start vehicle after a long stop (say 7 hours), vehicle struggle to move, especially when I start in the morning. After riding around 1 km all good.

    Here service guys told me first it is carburettor issue and cleaned it, it did not fix the issue.
    I went again to the showroom to complain, he told me it is normal, so I tested the same on 3 other brand new scooters in the showroom (Alpha, Ray Z and Ray ZR)
    In that first one(Alpha) I found the same issue.
    Second one did not have the issue(Ray Z) - which he told me that they did ride that scooter in the morning
    Third one showed same issue very slightly

    Can anyone tell if this is a serious issue and service centre guys just lying over it?

    ----consecutive posts auto-merged-----

    Quote Originally Posted by Dani52war View Post
    Okay I will buy a new rectifier and get the cdi check.

    Let us know if you find the solution, waiting for it.

  5. #15
    Rookie
    Join Date
    Jan 2018
    Location
    Hyderabad
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Yamaha Ray Z missing problem only when cold! Help me out guys

    Warm it up in the morning and tuning should be as everyday in the morning to start on one kick

Page 2 of 2 FirstFirst 12

Similar Threads

  1. FZ16 missing problem
    By Sarathnnj in forum Help Me!
    Replies: 1
    Last Post: 12-22-2018, 01:58 PM
  2. Royal Enfield Classic 350 BS4 Engine missing problem !
    By Sabyasachi Dey in forum Help Me!
    Replies: 1
    Last Post: 07-27-2018, 01:54 PM
  3. Rev missing/skipping problem
    By drive_angry in forum Help Me!
    Replies: 0
    Last Post: 06-19-2015, 06:36 PM
  4. Is this cold start problem in zma-r???
    By anmol_1990 in forum Help Me!
    Replies: 9
    Last Post: 11-18-2009, 11:21 PM
  5. New gen unicorn missing problem
    By becool in forum Help Me!
    Replies: 1
    Last Post: 08-11-2009, 09:42 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •