Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

Castrol Power 1

Learn & practice evasive maneuvers.

Our Partners

Announcement

Collapse
No announcement yet.

R15 V2 won't start.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • R15 V2 won't start.

    Hey Guys, This is my first post here, so forgive me if I make any mistakes. I recently bought a used R15 V2 which sat out in a car shed for almost 4 years. It was cheap and the body was in a good condition, so I decided to buy it and make it into a track bike.

    The bike had a rotten tank, and a real dirty fuel pump (images attached) , but I cleaned it all up and the pump works fine now.
    Then came the issue of the starter motor. It wouldn't work, so I changed the graphite brush and it works fine now.

    But now comes the main issue. Upon turning on the ignition, the fuel pump and the relays all work, and the starter motor rotates as well. BUT the magneto won't move. The gear which is behind the magneto moves with the starter motor, but the engine won't crank.

    Does anyone have any tips on what should be done next?
    Click image for larger version

Name:	Screenshot_20210512-112934.png
Views:	475
Size:	32.0 KB
ID:	2231688Click image for larger version

Name:	Screenshot_20210512-112948.png
Views:	103
Size:	25.4 KB
ID:	2231689

  • #2
    Topic approved.

    Comment


    • #3
      google seo
      Time is like a sharp It can carve hard lines on beautiful faces and wear out youth year after year, but using it well can make a piece of simple stone into a great statue. St. Mary Academy is still a simple piece of white stone briefly carved, but as time marches on, com it may be spoiled by dust, worn out by weather, or broken into separate pieces. It may be also carefully carved by knife into wonderful statues. Everyone at school, including our schoolmates, controls this knife.
      Last edited by prosocialclub; 05-14-2021, 01:22 PM.

      Comment


      • #4
        Originally posted by JustANooB View Post
        Hey Guys, This is my first post here, so forgive me if I make any mistakes. I recently bought a used R15 V2 which sat out in a car shed for almost 4 years. It was cheap and the body was in a good condition, so I decided to buy it and make it into a track bike.

        The bike had a rotten tank, and a real dirty fuel pump (images attached) , but I cleaned it all up and the pump works fine now.
        Then came the issue of the starter motor. It wouldn't work, so I changed the graphite brush and it works fine now.

        But now comes the main issue. Upon turning on the ignition, the fuel pump and the relays all work, and the starter motor rotates as well. BUT the magneto won't move. The gear which is behind the magneto moves with the starter motor, but the engine won't crank.

        Does anyone have any tips on what should be done next?
        Did you clean the throttle body, injector aswell?
        Also Replace oil filter, air filter.

        Check the current supply to/from the ignition coils, stator unit, regulator unit. Check for complete wiring, might be cracked or chewed due to rat bites etc

        Bajaj SuperFE 150 - Forever in my heart
        Bajaj Discover 135 DTSi Sports - 2009 to Current
        KTM RC390 - 2015 to Curr​ent
        TVS Jupiter - 2016 to Current

        Comment

        Working...
        X