Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

Castrol Power 1

Dawn & dusk make slight hard to adjust.

Our Partners

Announcement

Collapse

Welcome to xBhp Forums v2020

Welcome to 2020 Edition of the xBhp Forums . As you might have already noticed, the forums have undergone a major upgrade to keep up with the times. This will make the forums faster and intuitive and much more mobile friendly.

The basic functioning of the forum remains the same.

We are still tightening the loose nuts and bolts and it will take some time.

However, in case you are facing any issues or problems accessing the forums or posting here, please do let us know.

Any feedback/suggestions are also welcome!

You can post your suggestions on this thread itself!


https://www.xbhp.com/talkies/forum-a...s-2020-welcome
See more
See less

R15 V3 turns off at idle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • R15 V3 turns off at idle

    The bike turns off when no throttle input is given. I have to keep the rpm slightly higher to keep it running, video for reference:

    https://youtu.be/2hWqUpbg_gE

    I replaced spark plug and spark plug adapter and cleaned the fuel injector. Service center guys say to replace ECU and wiring Set for INR 8000/-. I don't know what it has to do with wiring set and ECU. Also this problem does not happen when I cold start it comes back after a few minutes. The bike has done only around 10k kms and is almost 2 years old. He showed me the diagnostics and there was a warning in atmospheric pressure sensor.

    Thanks for your help.
    Last edited by xBhp; 11-17-2020, 11:18 AM.

  • #2
    Re: R15 V3 turns off at idle

    Thread approved.

    Comment


    • #3
      Re: R15 V3 turns off at idle

      Originally posted by Hoardseeker View Post
      The bike turns off when no throttle input is given. I have to keep the rpm slightly higher to keep it running, video for reference:

      https://youtu.be/2hWqUpbg_gE

      I replaced spark plug and spark plug adapter and cleaned the fuel injector. Service center guys say to replace ECU and wiring Set for INR 8000/-. I don't know what it has to do with wiring set and ECU. Also this problem does not happen when I cold start it comes back after a few minutes. The bike has done only around 10k kms and is almost 2 years old. He showed me the diagnostics and there was a warning in atmospheric pressure sensor.

      Thanks for your help.

      Hey brother, Answer lies in last line itself, as Atmospheric pressure sensor is giving wrong or no signal to the ECU, due to which electronic Idling is not working, that's why as you giving throttle engine is working perfectly. any how idling is most relevant to throttle body and intake pipes sensors. Check wiring, measure voltage and continuity. If the bike is parked idle for few weeks, change entire the fuel first.
      Last edited by Vishal Wagh; 11-17-2020, 03:29 PM.

      Comment

      Working...
      X