Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

Castrol Power 1

Keep your helmet tightly strapped up.

Our Partners

Announcement

Collapse

Welcome to xBhp Forums v2020

Welcome to 2020 Edition of the xBhp Forums . As you might have already noticed, the forums have undergone a major upgrade to keep up with the times. This will make the forums faster and intuitive and much more mobile friendly.

The basic functioning of the forum remains the same.

We are still tightening the loose nuts and bolts and it will take some time.

However, in case you are facing any issues or problems accessing the forums or posting here, please do let us know.

Any feedback/suggestions are also welcome!

You can post your suggestions on this thread itself!


https://www.xbhp.com/talkies/forum-a...s-2020-welcome
See more
See less

R15 V2 missing on high RPM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • R15 V2 missing on high RPM

    I Have 2013 R15 V2. I installed Powertronic ECU on my bike (not tunable Powertronic but the standalone Powertronic which has 5 maps preloaded). After installing the ECU, the bike is missing on high RPM only. But with stock ECU, everything is fine. I have checked the fuel-injector too but there's no problem there.

    Any suggestions on what might be the problem?
    Last edited by xBhp; 11-20-2020, 07:20 PM.

  • #2
    re: R15 V2 missing on high RPM

    Thread approved.

    Comment

    Working...
    X