Since '02 xBhp is different things to different people. From a close knit national community of bikers to India's only motorcycling lifestyle magazine and a place to make like-minded biker friends. Join us

Castrol Power 1

Check engine oil level before every ride.

Our Partners

Announcement

Collapse
No announcement yet.

ZMR PGM-Fi MalFunction LED

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ZMR PGM-Fi MalFunction LED

    Hey Guyz,
    I m new to this community.
    Was reading the ZMR First Impressions Thread and was happy to see so many ZMR owners together.
    I myself have a White ZMR.

    I have a Question, I recently Purchased a White ZMR after Month Long Wait on 12th Aug.
    Yesterday i.e On Monday ..I had its First Service Done @ 805KMS.
    Bike Is Running like a Charm apart from a Couple of Things.

    1.I was involved in a 5-6KM Traffic Jam Today..In Delhi Heat..Suddenly I saw PGM-FI Malfunction Led Blinking....I was Speeding before The Jam and the Jam was Really Huge and to Make Matters Worse i had to go Through the Same Jam thrice due to Some Issue.
    So ofc i was already Slow in the Jam. After the Jam i switched off The Bike and Restarted..Led Did not Blink and Has not Blinked since. I have ridden abt 80 KMS Since then..and even took the Bike Till 122KMPH to Check it out but the Led Did not Blink or Flash even once..
    So what is the Issue..was it becoz of one of the Heat Sensors...which went hot during the Jam or any other problem??? Should I go and get The Bike Checked??

    2.I noticed that after 30-35Km Ride..(80-85KMPH) Bike Makes a small sound..most probably the Oil Cooling Pump i think which is on left Side top of the chassis rod... makes it..Is It Normal..??

    3.The Exhaust Pipe of the Bike Luks Plain and Empty...Has Anyone modded i.e Added Some GFX to it....or if somebody has Any Designs Do Let me know..

    4.HID...Which to Install...Cost...???

    Below Are Some Pics Of The Bike..Will add More Later...!!!
    ==ALL H@!L ThE TeRm!N@ToR==

  • #2
    Query approved and topic moved.
    Last edited by sunilg; 09-01-2010, 12:39 PM.
    (Been There Done That) x 3.25

    Comment


    • #3
      Take the bike to the service centre. Ask them to do all the diagnostics.

      It is due to some loose wiring. I faced this issue for a month or so. Changed the wiring & some sensors to make it run properly. Nothing to worry, Just tell them to run some diagnostics (with what ever tool they claim they have) & see to that all sensors are working properly
      Photo Gallery[/B]

      Comment


      • #4
        Originally posted by Mukul990 View Post
        Hey Guyz,
        I m new to this community.
        Was reading the ZMR First Impressions Thread and was happy to see so many ZMR owners together.
        I myself have a White ZMR.

        I have a Question, I recently Purchased a White ZMR after Month Long Wait on 12th Aug.
        Yesterday i.e On Monday ..I had its First Service Done @ 805KMS.
        Bike Is Running like a Charm apart from a Couple of Things.

        1.I was involved in a 5-6KM Traffic Jam Today..In Delhi Heat..Suddenly I saw PGM-FI Malfunction Led Blinking....I was Speeding before The Jam and the Jam was Really Huge and to Make Matters Worse i had to go Through the Same Jam thrice due to Some Issue.
        So ofc i was already Slow in the Jam. After the Jam i switched off The Bike and Restarted..Led Did not Blink and Has not Blinked since. I have ridden abt 80 KMS Since then..and even took the Bike Till 122KMPH to Check it out but the Led Did not Blink or Flash even once..
        So what is the Issue..was it becoz of one of the Heat Sensors...which went hot during the Jam or any other problem??? Should I go and get The Bike Checked??

        2.I noticed that after 30-35Km Ride..(80-85KMPH) Bike Makes a small sound..most probably the Oil Cooling Pump i think which is on left Side top of the chassis rod... makes it..Is It Normal..??

        3.The Exhaust Pipe of the Bike Luks Plain and Empty...Has Anyone modded i.e Added Some GFX to it....or if somebody has Any Designs Do Let me know..

        4.HID...Which to Install...Cost...???

        Below Are Some Pics Of The Bike..Will add More Later...!!!
        Yeah, get it checked there might be some problem. And are those stock ZMR bulbs?

        Comment


        • #5
          Originally posted by Mukul990 View Post
          Hey Guyz,
          I m new to this community.
          Was reading the ZMR First Impressions Thread and was happy to see so many ZMR owners together.
          I myself have a White ZMR.

          I have a Question, I recently Purchased a White ZMR after Month Long Wait on 12th Aug.
          Yesterday i.e On Monday ..I had its First Service Done @ 805KMS.
          Bike Is Running like a Charm apart from a Couple of Things.

          1.I was involved in a 5-6KM Traffic Jam Today..In Delhi Heat..Suddenly I saw PGM-FI Malfunction Led Blinking....I was Speeding before The Jam and the Jam was Really Huge and to Make Matters Worse i had to go Through the Same Jam thrice due to Some Issue.
          So ofc i was already Slow in the Jam. After the Jam i switched off The Bike and Restarted..Led Did not Blink and Has not Blinked since. I have ridden abt 80 KMS Since then..and even took the Bike Till 122KMPH to Check it out but the Led Did not Blink or Flash even once..
          So what is the Issue..was it becoz of one of the Heat Sensors...which went hot during the Jam or any other problem??? Should I go and get The Bike Checked??

          - Dude did you check your fuel levels, in-case you were running low on fuel at that moment then the pgm-fi malfunction indicator would light up, generally its always advisable you keep the 2ltr reserve fuel unused and have some extra

          2.I noticed that after 30-35Km Ride..(80-85KMPH) Bike Makes a small sound..most probably the Oil Cooling Pump i think which is on left Side top of the chassis rod... makes it..Is It Normal..??

          - No, this is not normal. I've taken my ZMR on continuous ride of 140 km only, as of now; at speeds of avg kph and faced no such issue. Do get this problem fixed at your SVC.

          3.The Exhaust Pipe of the Bike Luks Plain and Empty...Has Anyone modded i.e Added Some GFX to it....or if somebody has Any Designs Do Let me know..

          - Well i have no take on this as i personally have no issues with the stock one (as of now ) but i do intend to get my bike joelled ( he confirmed that apart from the re-bored engine even a better exhaust is available for the bike)

          4.HID...Which to Install...Cost...???

          - refer to this thread for your needs regarding HID's:
          " http://www.xbhp.com/talkies/universa...g-hid-etc.html "

          Answers to query in bold. Enjoy riding your bike.
          ____________________

          Planned, Unplanned and then Re-Planned - Ooty Ride

          SPARTAN CENTAUR Gloves: 10 DAYS, 3228 KMs: the Experience & Review

          The Boss Returns: Rebuilding 1991 Suzuki Shogun - In Progress

          I coined the term - " Closet Biker "

          Comment

          Working...
          X